What’s Vulnerable › Vulnerabilities
CVE-2021-25091: Link Library < 7.2.9 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Link Library WordPress plugin before 7.2.9 does not sanitise and escape the settingscopy parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting
Affected products
- Link Library: before 7.2.9 — fixed in 7.2.9
How to fix
Upgrade to a fixed version: Link Library 7.2.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/96204946-0b10-4a2c-8079-473883ff95b6
- https://wpscan.com/vulnerability/96204946-0b10-4a2c-8079-473883ff95b6
Get alerted when CVE-2021-25091 or the next vulnerability affects your stack