What’s Vulnerable › Vulnerabilities
CVE-2021-25095: IP2Location Country Blocker < 2.26.5 - Subscriber+ Arbitrary Country Ban
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-352
Description
The IP2Location Country Blocker WordPress plugin before 2.26.5 does not have authorisation and CSRF checks in the ip2location_country_blocker_save_rules AJAX action, allowing any authenticated users, such as subscriber to call it and block arbitrary country, or block all of them at once, preventing users from accessing the frontend.
Affected products
- IP2Location Country Blocker: before 2.26.5 — fixed in 2.26.5
How to fix
Upgrade to a fixed version: IP2Location Country Blocker 2.26.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2652469
- https://wpscan.com/vulnerability/cbfa7211-ac1f-4cf2-bd79-ebce2fc4baa1
- https://plugins.trac.wordpress.org/changeset/2652469
- https://wpscan.com/vulnerability/cbfa7211-ac1f-4cf2-bd79-ebce2fc4baa1
Get alerted when CVE-2021-25095 or the next vulnerability affects your stack