What’s Vulnerable › Vulnerabilities
CVE-2021-25101: Anti-Malware Security and Brute-Force Firewall < 4.20.94 - Admin+ Reflected Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Anti-Malware Security and Brute-Force Firewall WordPress plugin before 4.20.94 does not sanitise and escape the POST data before outputting it back in attributes of an admin page, leading to a Reflected Cross-Site scripting. Due to the presence of specific parameter value, available to admin users, this can only be exploited by an admin against another admin user.
Affected products
- Anti-Malware Security and Brute-Force Firewall: before 4.20.94 — fixed in 4.20.94
How to fix
Upgrade to a fixed version: Anti-Malware Security and Brute-Force Firewall 4.20.94. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5fd0380c-0d1d-4380-96f0-a07be5a61eba
- https://wpscan.com/vulnerability/5fd0380c-0d1d-4380-96f0-a07be5a61eba
Get alerted when CVE-2021-25101 or the next vulnerability affects your stack