What’s Vulnerable › Vulnerabilities
CVE-2021-25105: Ivory Search < 5.4.1 - Multiple Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ivory Search WordPress plugin before 5.4.1 does not escape some of the Form settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- vinod-dalvi Ivory Search – WordPress Search Plugin: before 5.4.1 — fixed in 5.4.1
How to fix
Upgrade to a fixed version: vinod-dalvi Ivory Search – WordPress Search Plugin 5.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a9ab9e84-7f5e-4e7c-8647-114d9e02e59f
- https://wpscan.com/vulnerability/a9ab9e84-7f5e-4e7c-8647-114d9e02e59f
Get alerted when CVE-2021-25105 or the next vulnerability affects your stack