What’s Vulnerable › Vulnerabilities
CVE-2021-25106: WPLegalPages < 2.7.1 - Subscriber+ Arbitrary Settings Update to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Privacy Policy Generator, Terms & Conditions Generator WordPress Plugin : WPLegalPages WordPress plugin before 2.7.1 does not check for authorisation and has a flawed CSRF logic when saving its settings, allowing any authenticated users, such as subscriber, to update them. Furthermore, due to the lack of sanitisation and escaping, it could lead to Stored Cross-Site Scripting
Affected products
- Privacy Policy Generator, Terms & Conditions Generator WordPress Plugin : WPLegalPages: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: Privacy Policy Generator, Terms & Conditions Generator WordPress Plugin : WPLegalPages 2.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/47df802d-5200-484b-959c-9f569edf992e
- https://wpscan.com/vulnerability/47df802d-5200-484b-959c-9f569edf992e
Get alerted when CVE-2021-25106 or the next vulnerability affects your stack