What’s Vulnerable › Vulnerabilities
CVE-2021-25112: WHMCS Bridge < 6.4b - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WHMCS Bridge WordPress plugin before 6.4b does not sanitise and escape the error parameter before outputting it back in admin dashboard, leading to a Reflected Cross-Site Scripting
Affected products
- WHMCS Bridge: before 6.4b — fixed in 6.4b
How to fix
Upgrade to a fixed version: WHMCS Bridge 6.4b. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2659751
- https://wpscan.com/vulnerability/4aae2dd9-8d51-4633-91bc-ddb53ca3471c
- https://plugins.trac.wordpress.org/changeset/2659751
- https://wpscan.com/vulnerability/4aae2dd9-8d51-4633-91bc-ddb53ca3471c
Get alerted when CVE-2021-25112 or the next vulnerability affects your stack