What’s Vulnerable › Vulnerabilities
CVE-2021-25117: WP Postratings < 1.86.1 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP-PostRatings WordPress plugin before 1.86.1 does not sanitise the postratings_image parameter from its options page (wp-admin/admin.php?page=wp-postratings/postratings-options.php). Even though the page is only accessible to administrators, and protected against CSRF attacks, the issue is still exploitable when the unfiltered_html capability is disabled.
Affected products
- Lester ‘GaMerZ’ Chan WP-PostRatings: before 1.86.1 — fixed in 1.86.1
How to fix
Upgrade to a fixed version: Lester ‘GaMerZ’ Chan WP-PostRatings 1.86.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d2d9a789-edae-4ae1-92af-e6132db7efcd/
- https://wpscan.com/vulnerability/d2d9a789-edae-4ae1-92af-e6132db7efcd/
Get alerted when CVE-2021-25117 or the next vulnerability affects your stack