What’s Vulnerable › Vulnerabilities
CVE-2021-25120: Easy Social Feed < 6.2.7 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Social Feed Free and Pro WordPress plugins before 6.2.7 do not sanitise some of their parameters used via AJAX actions before outputting them back in the response, leading to Reflected Cross-Site Scripting issues
Affected products
- sjaved Easy Social Feed – Social Photos Gallery and Post Feed for WordPress: before 6.2.7; before 6.3.4 — fixed in 6.2.7, 6.3.4
How to fix
Upgrade to a fixed version: sjaved Easy Social Feed – Social Photos Gallery and Post Feed for WordPress 6.2.7, 6.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0ad020b5-0d16-4521-8ea7-39cd206ab9f6
- https://wpscan.com/vulnerability/0ad020b5-0d16-4521-8ea7-39cd206ab9f6
Get alerted when CVE-2021-25120 or the next vulnerability affects your stack