What’s Vulnerable › Vulnerabilities
CVE-2021-25313: Rancher: XSS on /v3/cluster/
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Rancher allows remote attackers to execute JavaScript via malicious links. This issue affects: SUSE Rancher Rancher versions prior to 2.5.6.
Affected products
- SUSE Rancher: before 2.5.6 — fixed in 2.5.6
How to fix
Upgrade to a fixed version: SUSE Rancher 2.5.6. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=1181852
- https://github.com/rancher/rancher/issues/31583
- https://github.com/rancher/rancher/releases/tag/v2.5.6
- https://bugzilla.suse.com/show_bug.cgi?id=1181852
- https://github.com/rancher/rancher/issues/31583
- https://github.com/rancher/rancher/releases/tag/v2.5.6
Get alerted when CVE-2021-25313 or the next vulnerability affects your stack