What’s Vulnerable › Vulnerabilities

CVE-2021-25314: hawk: Insecure file permissions

Description

A Creation of Temporary File With Insecure Permissions vulnerability in hawk2 of SUSE Linux Enterprise High Availability 12-SP3, SUSE Linux Enterprise High Availability 12-SP5, SUSE Linux Enterprise High Availability 15-SP2 allows local attackers to escalate to root. This issue affects: SUSE Linux Enterprise High Availability 12-SP3 hawk2 versions prior to 2.6.3+git.1614685906.812c31e9. SUSE Linux Enterprise High Availability 12-SP5 hawk2 versions prior to 2.6.3+git.1614685906.812c31e9. SUSE Linux Enterprise High Availability 15-SP2 hawk2 versions prior to 2.6.3+git.1614684118.af555ad9.

Affected products

How to fix

Upgrade to a fixed version: SUSE Hawk2 2.6.3\+git.1614684118.af555ad9, 2.6.3\+git.1614685906.812c31e9, 2.6.3\+git.1614685906.812c31e9-2.42.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-25314 or the next vulnerability affects your stack