What’s Vulnerable › Vulnerabilities
CVE-2021-25318: rancher: API group not properly specified when creating Kubernetes RBAC resources
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-15 · updated 2026-06-17
- Weakness: CWE-732
Description
A Incorrect Permission Assignment for Critical Resource vulnerability in Rancher allows users in the cluster to modify resources they should not have access to. This issue affects: Rancher versions prior to 2.5.9 ; Rancher versions prior to 2.4.16.
Affected products
- Rancher: before 2.4.16; from 2.5.0 before 2.5.9 — fixed in 2.4.16, 2.5.9
How to fix
Upgrade to a fixed version: Rancher 2.4.16, 2.5.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-25318 or the next vulnerability affects your stack