What’s Vulnerable › Vulnerabilities
CVE-2021-25320: Rancher: Cloud credentials can be used through proxy API by users without access
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-15 · updated 2026-06-17
- Weakness: CWE-284
Description
A Improper Access Control vulnerability in Rancher, allows users in the cluster to make request to cloud providers by creating requests with the cloud-credential ID. Rancher in this case would attach the requested credentials without further checks This issue affects: Rancher versions prior to 2.5.9; Rancher versions prior to 2.4.16.
Affected products
- Rancher: before 2.4.16; from 2.5.0 before 2.5.9 — fixed in 2.4.16, 2.5.9
How to fix
Upgrade to a fixed version: Rancher 2.4.16, 2.5.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-25320 or the next vulnerability affects your stack