What’s Vulnerable › Vulnerabilities
CVE-2021-25322: python-HyperKitty: hyperkitty-permissions.sh used during %post allows local privilege escalation from hyperkitty user to root
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-10 · updated 2026-06-17
- Weakness: CWE-61
Description
A UNIX Symbolic Link (Symlink) Following vulnerability in python-HyperKitty of openSUSE Leap 15.2, Factory allows local attackers to escalate privileges from the user hyperkitty or hyperkitty-admin to root. This issue affects: openSUSE Leap 15.2 python-HyperKitty version 1.3.2-lp152.2.3.1 and prior versions. openSUSE Factory python-HyperKitty versions prior to 1.3.4-5.1.
Affected products
- Python-Hyperkitty Project Python-Hyperkitty: through 1.3.2-lp152.2.3.1; before 1.3.4-5.1 — fixed in 1.3.4-5.1
How to fix
Upgrade to a fixed version: Python-Hyperkitty Project Python-Hyperkitty 1.3.4-5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-25322 or the next vulnerability affects your stack