What’s Vulnerable › Vulnerabilities
CVE-2021-25630
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-23 · updated 2026-06-17
- Weakness: CWE-269
Description
"loolforkit" is a privileged program that is supposed to be run by a special, non-privileged "lool" user. Before doing anything else "loolforkit" checks, if it was invoked by the "lool" user, and refuses to run with privileges, if it's not the case. In the vulnerable version of "loolforkit" this check was wrong, so a normal user could start "loolforkit" and eventually get local root privileges.
Affected products
- Collaboraoffice Online: from 4.2.0 before 4.2.13; from 6.4.0 before 6.4.3 — fixed in 4.2.13, 6.4.3
How to fix
Upgrade to a fixed version: Collaboraoffice Online 4.2.13, 6.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/CollaboraOnline/online/security/advisories/GHSA-49w3-gr3w-m68v
- https://www.openwall.com/lists/oss-security/2021/01/18/3
- https://github.com/CollaboraOnline/online/security/advisories/GHSA-49w3-gr3w-m68v
- https://www.openwall.com/lists/oss-security/2021/01/18/3
Get alerted when CVE-2021-25630 or the next vulnerability affects your stack