What’s Vulnerable › Vulnerabilities
CVE-2021-25635: Content Manipulation with Certificate Validation Attack
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-21 · updated 2026-06-17
- Weakness: CWE-295
Description
An Improper Certificate Validation vulnerability in LibreOffice allowed an attacker to self sign an ODF document, with a signature untrusted by the target, then modify it to change the signature algorithm to an invalid (or unknown to LibreOffice) algorithm and LibreOffice would incorrectly present such a signature with an unknown algorithm as a valid signature issued by a trusted person This issue affects LibreOffice: from 7.0 before 7.0.5, from 7.1 before 7.1.1.
Affected products
- The Document Foundation LibreOffice: from 7.0.0 before 7.0.5.1; from 7.1.0.0 through 7.1.1.1 — fixed in 7.0.5.1
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 7.0.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-25635 or the next vulnerability affects your stack