What’s Vulnerable › Vulnerabilities
CVE-2021-25693
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-13 · updated 2026-06-17
- Weakness: CWE-476
Description
An attacker may cause a Denial of Service (DoS) in multiple versions of Teradici PCoIP Agent via a null pointer dereference.
Affected products
- Teradici Pcoip Agent: from 20.10 before 20.10.6; from 21.01 before 21.01.5; from 21.03 before 21.03.1 — fixed in 20.10.6, 21.01.5, 21.03.1
How to fix
Upgrade to a fixed version: Teradici Pcoip Agent 20.10.6, 21.01.5, 21.03.1. Check the vendor advisory for mitigations.
References
- https://advisory.teradici.com/security-advisories/79/
- https://advisory.teradici.com/security-advisories/79/
Get alerted when CVE-2021-25693 or the next vulnerability affects your stack