What’s Vulnerable › Vulnerabilities
CVE-2021-25698
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-21 · updated 2026-06-17
- Weakness: CWE-426
Description
The OpenSSL component of the Teradici PCoIP Standard Agent prior to version 21.07.0 was compiled without the no-autoload-config option, which allowed an attacker to elevate to the privileges of the running process via placing a specially crafted dll in a build configuration directory.
Affected products
- Teradici Pcoip Standard Agent: before 21.07.0 — fixed in 21.07.0
How to fix
Upgrade to a fixed version: Teradici Pcoip Standard Agent 21.07.0. Check the vendor advisory for mitigations.
References
- https://advisory.teradici.com/security-advisories/102/
- https://advisory.teradici.com/security-advisories/102/
Get alerted when CVE-2021-25698 or the next vulnerability affects your stack