What’s Vulnerable › Vulnerabilities
CVE-2021-25755
- Severity: low (CVSS 2.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-03 · updated 2026-06-17
Description
In JetBrains Code With Me before 2020.3, an attacker on the local network, knowing a session ID, could get access to the encrypted traffic.
Affected products
- JetBrains Code With Me: before 2020.3 — fixed in 2020.3
How to fix
Upgrade to a fixed version: JetBrains Code With Me 2020.3. Check the vendor advisory for mitigations.
References
- https://blog.jetbrains.com
- https://blog.jetbrains.com/blog/2021/02/03/jetbrains-security-bulletin-q4-2020/
- https://jay-from-future.github.io/cve/2021/04/02/code-with-me-cve.html
- https://blog.jetbrains.com
- https://blog.jetbrains.com/blog/2021/02/03/jetbrains-security-bulletin-q4-2020/
- https://jay-from-future.github.io/cve/2021/04/02/code-with-me-cve.html
Get alerted when CVE-2021-25755 or the next vulnerability affects your stack