What’s Vulnerable › Vulnerabilities
CVE-2021-25894
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Magnolia CMS from 6.1.3 to 6.2.3 contains a stored cross-site scripting (XSS) vulnerability in the /magnoliaPublic/travel/members/login.html mgnlUserId parameter.
Affected products
- Magnolia-Cms Magnolia Cms: from 6.1.3 before 6.1.7; from 6.2.3 before 6.2.4 — fixed in 6.1.7, 6.2.4
How to fix
Upgrade to a fixed version: Magnolia-Cms Magnolia Cms 6.1.7, 6.2.4. Check the vendor advisory for mitigations.
References
- https://git.magnolia-cms.com/projects/MODULES/repos/public-user-registration/commits/80c096c24d39ba2050b778e68ef838d79d4811dc
- https://www.itas.vn/itas-security-team-found-multi-vulnerabilities-on-magnolia-cms-platform/
- https://www.magnolia-cms.com/
- https://git.magnolia-cms.com/projects/MODULES/repos/public-user-registration/commits/80c096c24d39ba2050b778e68ef838d79d4811dc
- https://www.itas.vn/itas-security-team-found-multi-vulnerabilities-on-magnolia-cms-platform/
- https://www.magnolia-cms.com/
Get alerted when CVE-2021-25894 or the next vulnerability affects your stack