What’s Vulnerable › Vulnerabilities
CVE-2021-25902
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-26 · updated 2026-06-17
Description
An issue was discovered in the glsl-layout crate before 0.4.0 for Rust. When a panic occurs, map_array can perform a double drop.
Affected products
- Glsl-Layout Project Glsl-Layout: before 0.4.0 — fixed in 0.4.0
How to fix
Upgrade to a fixed version: Glsl-Layout Project Glsl-Layout 0.4.0. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2021-0005.html
- https://rustsec.org/advisories/RUSTSEC-2021-0005.html
Get alerted when CVE-2021-25902 or the next vulnerability affects your stack