What’s Vulnerable › Vulnerabilities
CVE-2021-25907
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-26 · updated 2026-06-17
- Weakness: CWE-415
Description
An issue was discovered in the containers crate before 0.9.11 for Rust. When a panic occurs, a util::{mutate,mutate2} double drop can be performed.
Affected products
- Containers Project Containers: before 0.9.11 — fixed in 0.9.11
How to fix
Upgrade to a fixed version: Containers Project Containers 0.9.11. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2021-0010.html
- https://rustsec.org/advisories/RUSTSEC-2021-0010.html
Get alerted when CVE-2021-25907 or the next vulnerability affects your stack