What’s Vulnerable › Vulnerabilities
CVE-2021-25924
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-01 · updated 2026-06-17
- Weakness: CWE-352
Description
In GoCD, versions 19.6.0 to 21.1.0 are vulnerable to Cross-Site Request Forgery due to missing CSRF protection at the `/go/api/config/backup` endpoint. An attacker can trick a victim to click on a malicious link which could change backup configurations or execute system commands in the post_backup_script field.
Affected products
- gocd: from 19.6.0 before 21.2.0 — fixed in 21.2.0
How to fix
Upgrade to a fixed version: gocd 21.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gocd/gocd/commit/7d0baab0d361c377af84994f95ba76c280048548
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25924%2C
- https://github.com/gocd/gocd/commit/7d0baab0d361c377af84994f95ba76c280048548
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25924%2C
Get alerted when CVE-2021-25924 or the next vulnerability affects your stack