What’s Vulnerable › Vulnerabilities
CVE-2021-25926
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the `quicksearch` feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.
Affected products
- sickrage: from 9.3.54 before 10.0.11; 10.0.11-dev1 — fixed in 10.0.11
How to fix
Upgrade to a fixed version: sickrage 10.0.11. Check the vendor advisory for mitigations.
References
- https://github.com/SiCKRAGE/SiCKRAGE/commit/9f42426727e16609ad3d1337f6637588b8ed28e4
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25926%2C
- https://github.com/SiCKRAGE/SiCKRAGE/commit/9f42426727e16609ad3d1337f6637588b8ed28e4
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25926%2C
Get alerted when CVE-2021-25926 or the next vulnerability affects your stack