What’s Vulnerable › Vulnerabilities

CVE-2021-25931

Description

In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.0-1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection at `/opennms/admin/userGroupView/users/updateUser`. This flaw allows assigning `ROLE_ADMIN` security role to a normal user. Using this flaw, an attacker can trick the admin user to assign administrator privileges to a normal user by enticing him to click upon an attacker-controlled website.

Affected products

How to fix

Upgrade to a fixed version: The OpenNMS Group Horizon 27.1.1; The OpenNMS Group Meridian 2019.1.19, 2020.1.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-25931 or the next vulnerability affects your stack