What’s Vulnerable › Vulnerabilities

CVE-2021-25933

Description

In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.0-1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to Stored Cross-Site Scripting, since the function `validateFormInput()` performs improper validation checks on the input sent to the `groupName` and `groupComment` parameters. Due to this flaw, an authenticated attacker could inject arbitrary script and trick other admin users into downloading malicious files which can cause severe damage to the organization using opennms.

Affected products

How to fix

Upgrade to a fixed version: The OpenNMS Group Horizon 27.1.1; The OpenNMS Group Meridian 2019.1.19, 2020.1.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-25933 or the next vulnerability affects your stack