What’s Vulnerable › Vulnerabilities
CVE-2021-25968: OpenCMS - Stored Cross-Site Scripting (XSS) in Sitemap
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-19 · updated 2026-06-17
- Weakness: CWE-79
Description
In “OpenCMS”, versions 10.5.0 to 11.0.2 are affected by a stored XSS vulnerability that allows low privileged application users to store malicious scripts in the Sitemap functionality. These scripts are executed in a victim’s browser when they open the page containing the vulnerable field.
Affected products
- Alkacon OpenCms: from 10.5.0 before 11.0.2 — fixed in 11.0.2
How to fix
Upgrade to a fixed version: Alkacon OpenCms 11.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/alkacon/mercury-template/commit/800945f5d02346c633c7aef9f5d596d7dedc8fb5
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25968
- https://github.com/alkacon/mercury-template/commit/800945f5d02346c633c7aef9f5d596d7dedc8fb5
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25968
Get alerted when CVE-2021-25968 or the next vulnerability affects your stack