What’s Vulnerable › Vulnerabilities
CVE-2021-25979: Apostrophe - Insufficient Session Expiration
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-613
Description
Apostrophe CMS versions prior to 3.3.1 did not invalidate existing login sessions when disabling a user account or changing the password, creating a situation in which a device compromised by a third party could not be locked out by those means. As a mitigation for older releases the user account in question can be archived (3.x) or moved to the trash (2.x and earlier) which does disable the existing session.
Affected products
- apostrophecms apostrophe: from 2.63.0 before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: apostrophecms apostrophe 3.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/apostrophecms/apostrophe/commit/c211b211f9f4303a77a307cf41aac9b4ef8d2c7c
- https://github.com/apostrophecms/apostrophe/commit/c211b211f9f4303a77a307cf41aac9b4ef8d2c7c
Get alerted when CVE-2021-25979 or the next vulnerability affects your stack