What’s Vulnerable › Vulnerabilities

CVE-2021-25981: Talkyard - Insufficient Session Expiration

Description

In Talkyard, regular versions v0.2021.20 through v0.2021.33 and dev versions v0.2021.20 through v0.2021.34, are vulnerable to Insufficient Session Expiration. This may allow an attacker to reuse the admin’s still-valid session token even when logged-out, to gain admin privileges, given the attacker is able to obtain that token (via other, hypothetical attacks)

Affected products

How to fix

Upgrade to a fixed version: debiki talkyard 0.2021.35. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-25981 or the next vulnerability affects your stack