What’s Vulnerable › Vulnerabilities
CVE-2021-26073
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-16 · updated 2026-06-17
- Weakness: CWE-287
Description
Broken Authentication in Atlassian Connect Express (ACE) from version 3.0.2 before version 6.6.0: Atlassian Connect Express is a Node.js package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Express app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Express versions from 3.0.2 before 6.6.0 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app.
Affected products
- Atlassian Connect Express (ACE): from 3.0.2 before 6.6.0 — fixed in 6.6.0
How to fix
Upgrade to a fixed version: Atlassian Connect Express (ACE) 6.6.0. Check the vendor advisory for mitigations.
References
- https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-a%5B%E2%80%A6%5Dypass-of-app-qsh-verification-via-context-jwts/47072
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1051986099
- https://security.netapp.com/advisory/ntap-20210604-0004/
- https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-a%5B%E2%80%A6%5Dypass-of-app-qsh-verification-via-context-jwts/47072
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1051986099
- https://security.netapp.com/advisory/ntap-20210604-0004/
Get alerted when CVE-2021-26073 or the next vulnerability affects your stack