What’s Vulnerable › Vulnerabilities
CVE-2021-26077
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-10 · updated 2026-06-17
- Weakness: CWE-287
Description
Broken Authentication in Atlassian Connect Spring Boot (ACSB) in version 1.1.0 before 2.1.3 and from version 2.1.4 before 2.1.5: Atlassian Connect Spring Boot is a Java Spring Boot package for building Atlassian Connect apps. Authentication between Atlassian products and the Atlassian Connect Spring Boot app occurs with a server-to-server JWT or a context JWT. Atlassian Connect Spring Boot versions 1.1.0 before 2.1.3 and versions 2.1.4 before 2.1.5 erroneously accept context JWTs in lifecycle endpoints (such as installation) where only server-to-server JWTs should be accepted, permitting an attacker to send authenticated re-installation events to an app.
Affected products
- Atlassian Connect Spring Boot (ACSB): from 1.1.0 before 2.1.3; from 2.1.4 before 2.1.5 — fixed in 2.1.3, 2.1.5
How to fix
Upgrade to a fixed version: Atlassian Connect Spring Boot (ACSB) 2.1.3, 2.1.5. Check the vendor advisory for mitigations.
References
- https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-allows-bypass-of-app-qsh-verification-via-context-jwts/47072
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1063555147
- https://community.developer.atlassian.com/t/action-required-atlassian-connect-vulnerability-allows-bypass-of-app-qsh-verification-via-context-jwts/47072
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1063555147
Get alerted when CVE-2021-26077 or the next vulnerability affects your stack