What’s Vulnerable › Vulnerabilities
CVE-2021-26084: Atlassian Confluence Server and Data Center Object-Graph Navigation Language (OGNL) Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-917
Description
In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.
Affected products
- Atlassian Confluence Data Center: before 6.13.23; from 6.14.0 before 7.4.11; from 7.5.0 before 7.11.6; from 7.12.0 before 7.12.5 — fixed in 6.13.23, 7.11.6, 7.12.5, 7.4.11
- Atlassian Confluence Data Center: before 6.13.23; from 6.14.0 before 7.4.11; from 7.5.0 before 7.11.6; from 7.12.0 before 7.12.5 — fixed in 6.13.23, 7.11.6, 7.12.5, 7.4.11
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 6.13.23, 7.11.6, 7.12.5, 7.4.11; Atlassian Confluence Data Center 6.13.23, 7.11.6, 7.12.5, 7.4.11. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/167449/Atlassian-Confluence-Namespace-OGNL-Injection.html
- https://jira.atlassian.com/browse/CONFSERVER-67940
- http://packetstormsecurity.com/files/167449/Atlassian-Confluence-Namespace-OGNL-Injection.html
- https://jira.atlassian.com/browse/CONFSERVER-67940
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-26084
Get alerted when CVE-2021-26084 or the next vulnerability affects your stack