What’s Vulnerable › Vulnerabilities
CVE-2021-26085: Atlassian Confluence Server Pre-Authorization Arbitrary File Read Vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-28
- EPSS: 99.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-03 · updated 2026-06-17
- Weakness: CWE-425
Description
Affected versions of Atlassian Confluence Server allow remote attackers to view restricted resources via a Pre-Authorization Arbitrary File Read vulnerability in the /s/ endpoint. The affected versions are before version 7.4.10, and from version 7.5.0 before 7.12.3.
Affected products
- Atlassian Confluence Data Center: before 7.4.10; from 7.5.0 before 7.12.3 — fixed in 7.12.3, 7.4.10
- Atlassian Confluence Data Center: before 7.4.10; from 7.5.0 before 7.12.3 — fixed in 7.12.3, 7.4.10
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.12.3, 7.4.10; Atlassian Confluence Data Center 7.12.3, 7.4.10. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/164401/Atlassian-Confluence-Server-7.5.1-Arbitrary-File-Read.html
- https://jira.atlassian.com/browse/CONFSERVER-67893
- http://packetstormsecurity.com/files/164401/Atlassian-Confluence-Server-7.5.1-Arbitrary-File-Read.html
- https://jira.atlassian.com/browse/CONFSERVER-67893
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-26085
Get alerted when CVE-2021-26085 or the next vulnerability affects your stack