What’s Vulnerable › Vulnerabilities
CVE-2021-26120
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 82.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-22 · updated 2026-06-17
- Weakness: CWE-94
Description
Smarty before 3.1.39 allows code injection via an unexpected function name after a {function name= substring.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Smarty: before 3.1.39 — fixed in 3.1.39
How to fix
Upgrade to a fixed version: Smarty 3.1.39. Check the vendor advisory for mitigations.
References
- https://github.com/smarty-php/smarty/blob/master/CHANGELOG.md
- https://lists.debian.org/debian-lts-announce/2021/04/msg00004.html
- https://lists.debian.org/debian-lts-announce/2021/04/msg00014.html
- https://security.gentoo.org/glsa/202105-06
- https://www.debian.org/security/2022/dsa-5151
- https://github.com/smarty-php/smarty/blob/master/CHANGELOG.md
- https://lists.debian.org/debian-lts-announce/2021/04/msg00004.html
- https://lists.debian.org/debian-lts-announce/2021/04/msg00014.html
- https://security.gentoo.org/glsa/202105-06
- https://www.debian.org/security/2022/dsa-5151
Get alerted when CVE-2021-26120 or the next vulnerability affects your stack