What’s Vulnerable › Vulnerabilities
CVE-2021-26543
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-78
Description
The "gitDiff" function in Wayfair git-parse <=1.0.4 has a command injection vulnerability. Clients of the git-parse library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. The issue has been resolved in version 1.0.5.
Affected products
- Wayfair Git-Parse: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Wayfair Git-Parse 1.0.5. Check the vendor advisory for mitigations.
References
- https://advisory.checkmarx.net/advisory/CX-2020-4302
- https://www.npmjs.com/package/git-parse
- https://advisory.checkmarx.net/advisory/CX-2020-4302
- https://www.npmjs.com/package/git-parse
Get alerted when CVE-2021-26543 or the next vulnerability affects your stack