What’s Vulnerable › Vulnerabilities
CVE-2021-26589
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-19 · updated 2026-06-17
- Weakness: CWE-732
Description
A potential security vulnerability has been identified in HPE Superdome Flex Servers. The vulnerability could be remotely exploited to allow Cross Site Scripting (XSS) because the Session Cookie is missing an HttpOnly Attribute. HPE has provided a firmware update to resolve the vulnerability in HPE Superdome Flex Servers.
Affected products
- HPE Superdome Flex 280 Firmware: before 3.40.106 — fixed in 3.40.106
- HPE Superdome Flex Firmware: before 3.40.106 — fixed in 3.40.106
How to fix
Upgrade to a fixed version: HPE Superdome Flex 280 Firmware 3.40.106; HPE Superdome Flex Firmware 3.40.106. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf04199en_us
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf04199en_us
Get alerted when CVE-2021-26589 or the next vulnerability affects your stack