What’s Vulnerable › Vulnerabilities

CVE-2021-26906

Description

An issue was discovered in res_pjsip_session.c in Digium Asterisk through 13.38.1; 14.x, 15.x, and 16.x through 16.16.0; 17.x through 17.9.1; and 18.x through 18.2.0, and Certified Asterisk through 16.8-cert5. An SDP negotiation vulnerability in PJSIP allows a remote server to potentially crash Asterisk by sending specific SIP responses that cause an SDP negotiation failure.

Affected products

How to fix

Upgrade to a fixed version: Digium Asterisk 13.38.2, 16.16.1, 17.9.2, 18.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-26906 or the next vulnerability affects your stack