What’s Vulnerable › Vulnerabilities
CVE-2021-26910
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-08 · updated 2026-06-17
- Weakness: CWE-367
Description
Firejail before 0.9.64.4 allows attackers to bypass intended access restrictions because there is a TOCTOU race condition between a stat operation and an OverlayFS mount operation.
Affected products
- Debian Linux: 9.0, 10.0
- Firejail Project Firejail: before 0.9.64.4 — fixed in 0.9.64.4
How to fix
Upgrade to a fixed version: Firejail Project Firejail 0.9.64.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/02/09/1
- https://github.com/netblue30/firejail/commit/97d8a03cad19501f017587cc4e47d8418273834b
- https://github.com/netblue30/firejail/releases/tag/0.9.64.4
- https://lists.debian.org/debian-lts-announce/2021/02/msg00015.html
- https://security.gentoo.org/glsa/202105-19
- https://unparalleled.eu/blog/2021/20210208-rigged-race-against-firejail-for-local-root/
- https://unparalleled.eu/publications/2021/advisory-unpar-2021-0.txt
- https://www.debian.org/security/2021/dsa-4849
- http://www.openwall.com/lists/oss-security/2021/02/09/1
- https://github.com/netblue30/firejail/commit/97d8a03cad19501f017587cc4e47d8418273834b
- https://github.com/netblue30/firejail/releases/tag/0.9.64.4
- https://lists.debian.org/debian-lts-announce/2021/02/msg00015.html
Get alerted when CVE-2021-26910 or the next vulnerability affects your stack