What’s Vulnerable › Vulnerabilities
CVE-2021-26923
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-15 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered in Argo CD before 1.8.4. Accessing the endpoint /api/version leaks internal information for the system, and this endpoint is not protected with authentication.
Affected products
- argoproj argo-cd: before 1.7.12; from 1.8.0 before 1.8.4 — fixed in 1.7.12, 1.8.4
How to fix
Upgrade to a fixed version: argoproj argo-cd 1.7.12, 1.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/argoproj/argo-cd/compare/v1.8.3...v1.8.4
- https://github.com/argoproj/argo-cd/security/advisories/GHSA-pfgj-mh5m-2p48
- https://github.com/argoproj/argo-cd/compare/v1.8.3...v1.8.4
- https://github.com/argoproj/argo-cd/security/advisories/GHSA-pfgj-mh5m-2p48
Get alerted when CVE-2021-26923 or the next vulnerability affects your stack