What’s Vulnerable › Vulnerabilities
CVE-2021-26945
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-400
Description
An integer overflow leading to a heap-buffer overflow was found in OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR.
Affected products
- AcademySoftwareFoundation openexr: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: AcademySoftwareFoundation openexr 3.0.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1947591
- https://bugzilla.redhat.com/show_bug.cgi?id=1947591
Get alerted when CVE-2021-26945 or the next vulnerability affects your stack