What’s Vulnerable › Vulnerabilities
CVE-2021-26953
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-09 · updated 2026-06-17
- Weakness: CWE-908
Description
An issue was discovered in the postscript crate before 0.14.0 for Rust. It might allow attackers to obtain sensitive information from uninitialized memory locations via a user-provided Read implementation.
Affected products
- Postscript Project Postscript: before 0.14.0 — fixed in 0.14.0
How to fix
Upgrade to a fixed version: Postscript Project Postscript 0.14.0. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2021-0017.html
- https://rustsec.org/advisories/RUSTSEC-2021-0017.html
Get alerted when CVE-2021-26953 or the next vulnerability affects your stack