What’s Vulnerable › Vulnerabilities
CVE-2021-27017: Deserialization of untrusted data
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-07 · updated 2026-06-17
- Weakness: CWE-502
Description
Utilization of a module presented a security risk by allowing the deserialization of untrusted/user supplied data. This is resolved in the Puppet Agent 7.4.0 release.
Affected products
- PuppetPu Puppet Agent: before 7.4.0 — fixed in 7.4.0
How to fix
Upgrade to a fixed version: PuppetPu Puppet Agent 7.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-27017 or the next vulnerability affects your stack