What’s Vulnerable › Vulnerabilities
CVE-2021-27018
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-295
Description
The mechanism which performs certificate validation was discovered to have a flaw that resulted in certificates signed by an internal certificate authority to not be properly validated. This issue only affects clients that are configured to utilize Tenable.sc as the vulnerability data source.
Affected products
- Puppet Remediate: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Puppet Remediate 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-27018 or the next vulnerability affects your stack