What’s Vulnerable › Vulnerabilities
CVE-2021-27019
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-532
Description
PuppetDB logging included potentially sensitive system information.
Affected products
- Puppet Enterprise: before 2019.8.6 — fixed in 2019.8.6
- Puppetdb: from 6.0.0 before 6.16.1; from 7.0.0 before 7.3.1 — fixed in 6.16.1, 7.3.1
How to fix
Upgrade to a fixed version: Puppet Enterprise 2019.8.6; Puppetdb 6.16.1, 7.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-27019 or the next vulnerability affects your stack