What’s Vulnerable › Vulnerabilities
CVE-2021-27020
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-1236
Description
Puppet Enterprise presented a security risk by not sanitizing user input when doing a CSV export.
Affected products
- Puppet Enterprise: before 2019.8.6 — fixed in 2019.8.6
How to fix
Upgrade to a fixed version: Puppet Enterprise 2019.8.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-27020 or the next vulnerability affects your stack