What’s Vulnerable › Vulnerabilities
CVE-2021-27021
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-20 · updated 2026-06-17
- Weakness: CWE-1027
Description
A flaw was discovered in Puppet DB, this flaw results in an escalation of privileges which allows the user to delete tables via an SQL query.
Affected products
- Puppet Agent: before 6.23.0; from 7.7.0 before 7.8.0 — fixed in 6.23.0, 7.8.0
- Puppet Enterprise: before 2019.8.7; from 2021.0.0 before 2021.2.0 — fixed in 2019.8.7, 2021.2.0
- Puppetdb: before 6.17.0; from 7.0.0 before 7.4.1 — fixed in 6.17.0, 7.4.1
How to fix
Upgrade to a fixed version: Puppet Agent 6.23.0, 7.8.0; Puppet Enterprise 2019.8.7, 2021.2.0; Puppetdb 6.17.0, 7.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-27021 or the next vulnerability affects your stack