What’s Vulnerable › Vulnerabilities
CVE-2021-27022
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-07 · updated 2026-06-17
- Weakness: CWE-532
Description
A flaw was discovered in bolt-server and ace where running a task with sensitive parameters results in those sensitive parameters being logged when they should not be. This issue only affects SSH/WinRM nodes (inventory service nodes).
Affected products
- Puppet Agent: from 2021.0.0 before 2021.3.0 — fixed in 2021.3.0
- Puppet Enterprise: before 2019.8.8 — fixed in 2019.8.8
How to fix
Upgrade to a fixed version: Puppet Agent 2021.3.0; Puppet Enterprise 2019.8.8. Check the vendor advisory for mitigations.
References
- https://puppet.com/security/cve/cve-2021-27022/
- https://puppet.com/security/cve/cve-2021-27022/%5D
- https://puppet.com/security/cve/cve-2021-27022/
- https://puppet.com/security/cve/cve-2021-27022/%5D
Get alerted when CVE-2021-27022 or the next vulnerability affects your stack