What’s Vulnerable › Vulnerabilities
CVE-2021-27024
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-18 · updated 2026-06-17
Description
A flaw was discovered in Continuous Delivery for Puppet Enterprise (CD4PE) that results in a user with lower privileges being able to access a Puppet Enterprise API token. This issue is resolved in CD4PE 4.10.0
Affected products
- Continuous Delivery for Puppet Enterprise (CD4PE): before 4.10.0 — fixed in 4.10.0
How to fix
Upgrade to a fixed version: Continuous Delivery for Puppet Enterprise (CD4PE) 4.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-27024 or the next vulnerability affects your stack