What’s Vulnerable › Vulnerabilities
CVE-2021-27098
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-05 · updated 2026-06-17
- Weakness: CWE-295
Description
In SPIRE 0.8.1 through 0.8.4 and before versions 0.9.4, 0.10.2, 0.11.3 and 0.12.1, specially crafted requests to the FetchX509SVID RPC of SPIRE Server’s Legacy Node API can result in the possible issuance of an X.509 certificate with a URI SAN for a SPIFFE ID that the agent is not authorized to distribute. Proper controls are in place to require that the caller presents a valid agent certificate that is already authorized to issue at least one SPIFFE ID, and the requested SPIFFE ID belongs to the same trust domain, prior to being able to trigger this vulnerability. This issue has been fixed in SPIRE versions 0.8.5, 0.9.4, 0.10.2, 0.11.3 and 0.12.1.
Affected products
- Cncf Spire: from 0.8.1 through 0.8.4; from 0.9.0 before 0.9.4; from 0.10.0 before 0.10.2; from 0.11.0 before 0.11.3; from 0.12.0 before 0.12.1 — fixed in 0.10.2, 0.11.3, 0.12.1, 0.9.4
How to fix
Upgrade to a fixed version: Cncf Spire 0.10.2, 0.11.3, 0.12.1, 0.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/spiffe/spire/security/advisories/GHSA-h746-rm5q-8mgq
- https://github.com/spiffe/spire/security/advisories/GHSA-h746-rm5q-8mgq
Get alerted when CVE-2021-27098 or the next vulnerability affects your stack