What’s Vulnerable › Vulnerabilities
CVE-2021-27185
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-10 · updated 2026-06-17
- Weakness: CWE-77
Description
The samba-client package before 4.0.0 for Node.js allows command injection because of the use of process.exec.
Affected products
- Samba-Client Project Samba-Client: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Samba-Client Project Samba-Client 4.0.0. Check the vendor advisory for mitigations.
References
- https://advisory.checkmarx.net/advisory/CX-2021-4302
- https://github.com/eflexsystems/node-samba-client/commit/5bc3bbad9b8d02243bc861a11ec73f788fbb1235
- https://github.com/eflexsystems/node-samba-client/releases/tag/4.0.0
- https://security.netapp.com/advisory/ntap-20210319-0002/
- https://www.npmjs.com/package/samba-client
- https://advisory.checkmarx.net/advisory/CX-2021-4302
- https://github.com/eflexsystems/node-samba-client/commit/5bc3bbad9b8d02243bc861a11ec73f788fbb1235
- https://github.com/eflexsystems/node-samba-client/releases/tag/4.0.0
- https://security.netapp.com/advisory/ntap-20210319-0002/
- https://www.npmjs.com/package/samba-client
Get alerted when CVE-2021-27185 or the next vulnerability affects your stack