What’s Vulnerable › Vulnerabilities
CVE-2021-27191
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-11 · updated 2026-06-17
Description
The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion.
Affected products
- Get-Ip-Range Project Get-Ip-Range: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Get-Ip-Range Project Get-Ip-Range 4.0.0. Check the vendor advisory for mitigations.
References
- https://advisory.checkmarx.net/advisory/CX-2021-4304
- https://github.com/JoeScho/get-ip-range/commit/98ca22b815c77273cbab259811ab0976118e13b6
- https://security.netapp.com/advisory/ntap-20210319-0002/
- https://www.npmjs.com/package/get-ip-range
- https://advisory.checkmarx.net/advisory/CX-2021-4304
- https://github.com/JoeScho/get-ip-range/commit/98ca22b815c77273cbab259811ab0976118e13b6
- https://security.netapp.com/advisory/ntap-20210319-0002/
- https://www.npmjs.com/package/get-ip-range
Get alerted when CVE-2021-27191 or the next vulnerability affects your stack